MP2672A is not working

I’m having a lot of trouble with the MP2672A. First I tried to use in the standalone mode, it didn’t work, so I tried to use it in the host control mode, it didn’t work. I’ll share some information about what I have done, please take a look and try to help me.

1st, the schematic:

2nd, ther ESP32 code part where I send the registers:

  Wire.beginTransmission(0x4B); // Device address
  Wire.write(0x02);             // Register address
  Wire.write(0b00001000);       // Register 0x02

  Wire.beginTransmission(0x4B); // Device address
  Wire.write(0x02);             // Register address
  Wire.write(0b01000000);       // Register 0x02

  Wire.beginTransmission(0x4B); // Device address
  Wire.write(0x00);             // Register address
  Wire.write(0b00111110);       // Register 0x00
  Wire.write(0b00001111);       // Register 0x01
  Wire.write(0b10000000);       // Register 0x02

3rd, when the registers are read:
Register 0x00 => Values 00111110
Register 0x01 => Values 00001111
Register 0x02 => Values 10000000
Register 0x03 => Values 00000001
Register 0x04 => Values 10110000

So, some problems:

  • Everytime that I change something more in the register 0x02, like put the CHG_TMR to a different value or the EN_SUSP to 1, the registers go crazy, I start to get different readings every reading cycle, and it seems that everything goes to default.
  • It doesn’t matter what I do, I’m always having thermal shutdown fault (register 4) and watchdog error, even having disabled the watchdog timer.
  • The ACOK pin is always low, so the LED is always ON, and the STAT pin is always blinking in high frequency. How it will be these signals is a normal operation mode?

Important things:

  • The MID pin is connected to the ground, so I’m not using the balance function.
  • The battery is a 2-cell 7.4V li ion.
  • The CV pin has a resistor in this schematic, but to use I2C and get the results I have shown here, I connected it to VCC, to activate the host control mode.

Please guide me in some tests that I can do to use this solution in the product that we are developing.
Thanks in advance.

Hello, can someone help me with this issue?

Hi Eric,

Thank you for contacting the MPS Forum. Let’s start with putting the device into standalone mode again. The ACOK LED notifying good input power is encouraging. Let’s see if we can get some scope captures. I want to see VIN, VSW, VBATT and IBATT if you can capture that. Is there a system voltage as well? Can you tell me the inductor that you are using as well?

I’m hoping these things can help show me what the issue is.