MP2639A current charge not expected

Hi everyone.
I am carrying out the design of a battery charge with the MP2639A and everything works correctly except the charge current.
I have defined Rset = 470Kohm → Iset(Load current) = 450mA and Rlim = 270Kohm —> Ilim = 790mA and I have a 2S battery. I have run several tests:
-Battery half charged, battery completely discharged etc… and I always get a charging current of 250mA. I am powering through a microUSB port connected to a power supply to control the current supplied. The curious thing is that even if you change Rlim and ask for more current, the battery charging current (Iset) is always half the current set by the power supply. And the rest of the current I don’t know where it goes. There is nothing else connected to the microUSB port, only the MPS is connected and a voltage divider to detect that there is 5V and change the MPS from charging to discharging. Some help?
Thanks in advance

Are you using a decent quality resistor with low tolerance on IB? I’ve not used this chiP but the MP2637GR has a similar setup and I had similar issues with unexpected charge current (lower than expected) turned out to be the additional resistance of tracks on a 20mOhm current sense resistor. Obviously your using much higher values that will be almost immune to those sorts of issues but it might be a place to start.

Perhaps try some different values for IB and see how it effects the current versus your predictions from calcs.

Hope it helps in some way.

Hello ggutierrez,

Could you let me know what your operating conditions are? What is your input voltage, input current, output current, output voltage, and battery voltage?

Could you try powering the device without the micro-USB cable?
Could you try increasing ILIM?

Vinh Tran

Hi Michael.
first of all thank you for your answer. I have tried increasing Rib values but no changes in the battery charging current are appreciated. On the other hand I have two schemes made. One with the RIB resistors and one without them and the result is the same. I’ll keep trying. When I find the solution, I’ll post it.
Have a nice day

Hello Vinh.
Thank you for answering. I answer each question below.
Could you tell me what are its operating conditions? What is your input voltage, input current, output current, output voltage and battery voltage?
The supply voltage and supply current are provided by a power supply Vin = 5V // Iin = 800mA (limited)
The conditions in which I put the battery to charge are:
Vbatt = 7.4V and the charging current is Ibatt = 126mA

Could you try to power on the device without the micro-USB cable?
I’ve tried and it doesn’t fix it.
Could you try to increase ILIM?
It would be convenient not to increase the ILIM since it should be able to be charged through the USB port of a computer, so IILIM would have to be limited to 500mA.
fuente alimentación.PNG