MTP password does not work

Hi Cindy,
I tried to enter the password you sent me 0x05 followed by 0x19 in register 25 of an MPQ7920_000 but it does not work !! When I write 0x80 in register 26 to enter in MTP_mode, no buck output shut down !?!? I also tried to execute the following script :
SET ADDRESS=69
26 WRITE_BYTE 05
26 WRITE_BYTE 19
25 WRITE_BYTE 80
I get the same result : all the output voltages stay present and I can not go further in the programming procedure ! Could you please confirm I used the good pair of passwords (in hexadecimal) or tell me why it does not work ? I would really appeciate to have a support from your side. I need to test my parameters during a real power startup.Thanks in advance and regards. Pierre

Hi p.stassain,

Can you confirm you are following the MTP program process on page 7 of the User Guide:

Thanks,
Cindy

Hi Cindy,
No, I followed the instructions of page 20 of the datasheet… I did not have either this MPQ7920 GUI (shown in your mail) nor the corresponding user guide because I did not found them on your website. could you give me the link to download this user guide ?? Thanks & regards. Pierre

Hi p.stassain,

I’ll need to email you the user guide since it needs to be watermarked. Can you provide the company you work for and an email address?

Thanks,
Cindy

Thanks for your email.

My company name and email are in my profil on your website…

You will find here below for your convenience :

CE+T Power SA

L-9911 Troisvierges

Luxembourg

My email : p.stassain@cet-power.com

Could you please send me the installation files of the MPQ7920 GUI tools together with the user guide ?

I already asked Sunandhitha and mpsnow for the GUI files but I did not receive any answer!

Thanks for your help and kind regards

Hi there,

Thanks for providing that information. I went ahead and emailed you the user guide.
You can download the GUI here: https://www.monolithicpower.com/en/virtual-bench-pro-4-0.html.

Thanks,
Cindy

Got the user guide now !! Many thanks Cindy

Pierre

1 Like